This is a provider package for
apache.livy provider. All classes for this provider package
airflow.providers.apache.livy python package.
You can install this package on top of an existing Airflow 2 installation (see
for the minimum Airflow version supported) via
pip install apache-airflow-providers-apache-livy
The minimum Apache Airflow version supported by this provider package is
Cross provider package dependencies¶
Those are dependencies that might be needed in order to use all the features of the package. You need to install the specified provider packages in order to use them.
You can install such cross-provider dependencies when installing from PyPI. For example:
pip install apache-airflow-providers-apache-livy[http]
Downloading official packages¶
You can download officially released packages and verify their checksums and signatures from the Official Apache Download site
The apache-airflow-providers-apache-livy 3.5.0 sdist package (asc, sha512)
The apache-airflow-providers-apache-livy 3.5.0 wheel package (asc, sha512)
This release of provider is only available for Airflow 2.4+ as explained in the Apache Airflow providers support policy.
Bump minimum Airflow version in providers (#30917)
This release of provider is only available for Airflow 2.3+ as explained in the Apache Airflow providers support policy.
Move min airflow version to 2.3.0 for all providers (#27196)
Add template to livy operator documentation (#27404)
Add Spark's 'appId' to xcom output (#27376)
add template field renderer to livy operator (#27321)
This release of provider is only available for Airflow 2.2+ as explained in the Apache Airflow providers support policy.
Fix: Add extra headers to all livy API requests instead of only to post_batch (#22510)
Added retries to LivyHook #19384 (#21550)
Support for Python 3.10
add how-to guide for livy operator (#21529)
Fetching and logging livy session logs for LivyOperrator (#17393)
Optimise connection importing for Airflow 2.2.0
Auto-apply apply_default decorator (#15667)
Due to apply_default decorator removal, this version of the provider requires Airflow 2.1.0+.
If your Airflow version is < 2.1.0, and you want to install this provider version, first upgrade
Airflow to at least version 2.1.0. Otherwise your Airflow package version will be upgraded
automatically and you will have to manually run
airflow upgrade db to complete the migration.
Updated documentation and readme files.
Initial version of the provider.