This is a provider package for
postgres provider. All classes for this provider package
airflow.providers.postgres python package.
You can install this package on top of an existing Airflow 2 installation (see
for the minimum Airflow version supported) via
pip install apache-airflow-providers-postgres
Cross provider package dependencies¶
Those are dependencies that might be needed in order to use all the features of the package. You need to install the specified provider packages in order to use them.
You can install such cross-provider dependencies when installing from PyPI. For example:
pip install apache-airflow-providers-postgres[amazon]
Downloading official packages¶
You can download officially released packages and verify their checksums and signatures from the Official Apache Download site
Use only public AwsHook's methods during IAM authorization (#25424)
Unify DbApiHook.run() method with the methods which override it (#23971)
This release of provider is only available for Airflow 2.2+ as explained in the Apache Airflow providers support policy https://github.com/apache/airflow/blob/main/README.md#support-for-providers
adds ability to pass config params to postgres operator (#21551)
Fix mistakenly added install_requires for all providers (#22382)
The URIs returned by Postgres
postgres:// prefix which is the only supported prefix for the
SQLAlchemy 1.4.0+. Any usage of
should be updated to reflect it.
Replaces the usage of postgres:// with postgresql:// (#21205)
Add more SQL template fields renderers (#21237)
Add conditional 'template_fields_renderers' check for new SQL lexers (#21403)
Support for Python 3.10
19489 - Pass client_encoding for postgres connections (#19827)
Amazon provider remove deprecation, second try (#19815)
Added upsert method on S3ToRedshift operator (#18027)
Fix example dag of PostgresOperator (#18236)
Make schema in DBApiHook private (#17423)
Optimise connection importing for Airflow 2.2.0
Auto-apply apply_default decorator (#15667)
Due to apply_default decorator removal, this version of the provider requires Airflow 2.1.0+.
If your Airflow version is < 2.1.0, and you want to install this provider version, first upgrade
Airflow to at least version 2.1.0. Otherwise your Airflow package version will be upgraded
automatically and you will have to manually run
airflow upgrade db to complete the migration.
PostgresHook: deepcopy connection to avoid mutating connection obj (#15412)
Do not forward cluster-identifier to psycopg2 (#15360)
Updated documentation and readme files. Added HowTo guide for Postgres Operator.
Initial version of the provider.