apache-airflow-providers-celery

Package apache-airflow-providers-celery

Celery

Release: 2.1.0

Provider package

This is a provider package for celery provider. All classes for this provider package are in airflow.providers.celery python package.

Installation

You can install this package on top of an existing airflow 2.1+ installation via pip install apache-airflow-providers-celery

PIP requirements

PIP package

Version required

apache-airflow

>=2.1.0

celery

~=5.1,>=5.1.2

flower

~=1.0.0

Changelog

2.1.0

Features

  • The celery provider is converted to work with Celery 5 following airflow 2.2.0 change of Celery version

2.0.0

Breaking changes

  • Auto-apply apply_default decorator (#15667)

Warning

Due to apply_default decorator removal, this version of the provider requires Airflow 2.1.0+. If your Airflow version is < 2.1.0, and you want to install this provider version, first upgrade Airflow to at least version 2.1.0. Otherwise your Airflow package version will be upgraded automatically and you will have to manually run airflow upgrade db to complete the migration.

1.0.1

Updated documentation and readme files.

1.0.0

Initial version of the provider.

Was this entry helpful?